易语言PathFindSuffixArrayA寻找路径后缀数组

寻找路径后缀数组PathFindSuffixArrayA

.版本 2
 
.DLL命令 寻找路径后缀数组_, 整数型, "shlwapi.dll", "PathFindSuffixArrayA"
    .参数 路径文本, 文本型, , pszPath
    .参数 后缀数组, 文本型, 数组, apszSuffix
    .参数 数组成员数, 整数型, , iArraySize

易语言调用

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 程序集_后缀数组, 文本型, , "0"

.子程序 __启动窗口_创建完毕

' PathFindSuffixArrayA的作用是根据文本数组在路径文本中寻找后缀。
' 找到返回变量指针地址,找不到返回0。
列表框_后缀列表.加入项目 (“txt”, )
列表框_后缀列表.加入项目 (“exe”, )
列表框_后缀列表.加入项目 (“tmp”, )
列表框_后缀列表.加入项目 (“bmp”, )
列表框_后缀列表.加入项目 (“jpg”, )
列表框_后缀列表.加入项目 (“doc”, )
加入成员 (程序集_后缀数组, “txt”)
加入成员 (程序集_后缀数组, “exe”)
加入成员 (程序集_后缀数组, “tmp”)
加入成员 (程序集_后缀数组, “bmp”)
加入成员 (程序集_后缀数组, “jpg”)
加入成员 (程序集_后缀数组, “doc”)

.子程序 _按钮_加入_被单击

.如果真 (编辑框_后缀.内容 ≠ “”)
列表框_后缀列表.加入项目 (编辑框_后缀.内容, )
加入成员 (程序集_后缀数组, 编辑框_后缀.内容)
.如果真结束

.子程序 _按钮_寻找路径后缀数组_被单击
.局部变量 局部_路径文本, 文本型
.局部变量 局部_指针, 整数型

局部_路径文本 = 编辑框_路径.内容
局部_指针 = 寻找路径后缀数组_ (局部_路径文本, 程序集_后缀数组, 取数组成员数 (程序集_后缀数组))
编辑框_指针地址.内容 = 到文本 (局部_指针)
.判断开始 (局部_指针 = 0)
编辑框_返回.内容 = “没有找到后缀”
.默认
编辑框_返回.内容 = 指针到文本 (局部_指针)
.判断结束


发布日期:

所属分类: 易语言 标签: