易语言大漠多线程模块制作及游戏实战方法2-多线程类模块制作

类多线程模块核心源码

.版本 2

.程序集 类_多线程, , 公开, 多线程模块,主要调用方法
.程序集变量 obj, 对象, , "100"

.子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用

创建目录 (取运行目录 () + “\360SafeBin”)
置文件属性 (取运行目录 () + “\360SafeBin”, 2 + 4)
写到文件 (取运行目录 () + “\360SafeBin\360reg.dll”, #DumpUperReg)
置文件属性 (取运行目录 () + “\360SafeBin\360reg.dll”, 2 + 4)

.子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用

.子程序 插件初始化, , 公开
.参数 是否收费版本, 逻辑型, 可空, 默认为空则为免费版
.参数 索引, 整数型

.判断开始 (是否收费版本)
写到文件 (取运行目录 () + “\360SafeBin\360inisf.dll”, #Basesf)
置文件属性 (取运行目录 () + “\360SafeBin\360inisf.dll”, 2 + 4)
SetDllPathA (取运行目录 () + “\360SafeBin\360inisf.dll”, 0)
obj [索引].创建 (“dm.dmsoft”, )

.默认
写到文件 (取运行目录 () + “\360SafeBin\360verfree.dll”, #freedback)
置文件属性 (取运行目录 () + “\360SafeBin\360verfree.dll”, 2 + 4)
SetDllPathA (取运行目录 () + “\360SafeBin\360verfree.dll”, 0)
obj [索引].创建 (“dm.dmsoft”, )
.判断结束

.子程序 BindWindow, 整数型, 公开, 后台绑定窗口(返回值:0 失败,1 成功)
.参数 hwnd, 整数型, , 指定窗口的句柄
.参数 display, 文本型, , 屏幕颜色获取方式
.参数 mouse, 文本型, , 鼠标仿真模式
.参数 keypad, 文本型, , 键盘仿真模式
.参数 mode, 整数型, , 模式,见接口说明
.参数 索引, 整数型, , 多线程的序号索引值

返回 (obj [索引].数值方法 (“BindWindow”, hwnd, display, mouse, keypad, mode))

.子程序 UnBindWindow, 整数型, 公开, 解除绑定窗口,并释放系统资源,(返回值:0 失败,1 成功)
.参数 索引, 整数型, , 多线程的序号索引值

返回 (obj [索引].数值方法 (“UnBindWindow”, ))

.子程序 KeyPress, 整数型, 公开, 按下指定的虚拟键码(返回值:0 失败,1 成功)
.参数 vk_code, 整数型, , 虚拟按键码
.参数 索引, 整数型, , 多线程的序号索引值

返回 (obj [索引].数值方法 (“KeyPress”, vk_code))

.子程序 销毁, , 公开
.参数 索引, 整数型

obj [索引].清除 ()


发布日期:

所属分类: 易语言 标签: