大漠多线程循环任务自动切换模板-5监控反馈及线程结束

监控反馈及线程结束源码:

.版本 2
.支持库 iext
.支持库 EThread
 
.子程序 监控反馈, , , 反馈线程执行情况
.参数 索引, 整数型, , 主线程的索引
.参数 事件, 文本型
 
窗口列表.置标题 (索引 - 1, 4, 事件)
 
.子程序 停止, , , 还原状态,解绑窗口,结束线程,
.局部变量 索引
 
按钮_开始.标题 = “全部开始”
超级延时 (1000, )
' 要根据游戏窗口的数量来完成窗口的操作
.计次循环首 (窗口列表.取表项数 (), 索引)
    线程 [索引].运行状态 = 0
    监控反馈 (索引, “窗口任务已停止”)
    ' 开始解绑
    线程 [索引].dm.UnBindWindow ()
    ' 还原一下窗口状态
    线程 [索引].dm.SetWindowState (到整数 (窗口列表.取标题 (索引 - 1, 3)), 5)
    ' 结束一下线程句柄,释放资源
    强制结束线程 (线程 [索引].线程句柄)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: