易语言教程移动文件复制文件删除文件

系统核心支持库-复制移动删除文件

新命令
1、复制文件()
2、移动文件()
3、删除文件()
用到的命令(复习)
1、取文本右边()
2、取文本长度()
3、倒找文本()
4、浏览文件夹()
5、取运行目录 ()
新组建
拖放对象

视频教程源码:

.版本 2
.支持库 edroptarget
.支持库 shell

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (编辑框_源文件路径.取窗口句柄 ())

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型

编辑框_源文件路径.内容 = 接收到的文件路径

.子程序 _按钮1_被单击

编辑框_新文件路径.内容 = 浏览文件夹 (“保存路径”, )

.子程序 _按钮2_被单击, , , 移动文件
.局部变量 文件名, 文本型
.局部变量 str, 逻辑型

' C:\Users\zcp\Desktop\易语言教程-39\测试.txt
文件名 = 取文本右边 (编辑框_源文件路径.内容, 取文本长度 (编辑框_源文件路径.内容) - 倒找文本 (编辑框_源文件路径.内容, “\”, , 假))
str = 移动文件 (编辑框_源文件路径.内容, 编辑框_新文件路径.内容 + “\” + 文件名)
.如果 (str = 真)
标签3.标题 = “移动成功!”
.否则
标签3.标题 = “移动失败!”
.如果结束

.子程序 _按钮3_被单击, , , 复制文件
.局部变量 str, 逻辑型
.局部变量 文件名, 文本型

' 复制文件 (, )
文件名 = 取文本右边 (编辑框_源文件路径.内容, 取文本长度 (编辑框_源文件路径.内容) - 倒找文本 (编辑框_源文件路径.内容, “\”, , 假))
str = 复制文件 (编辑框_源文件路径.内容, 编辑框_新文件路径.内容 + “\” + 文件名)
.如果 (str = 真)
标签3.标题 = “复制成功!”
.否则
标签3.标题 = “复制失败!”
.如果结束

.子程序 _按钮4_被单击, , , 删除文件
.局部变量 str, 逻辑型

str = 删除文件 (编辑框_源文件路径.内容)

.如果 (str = 真)
标签3.标题 = “删除成功!”
.否则
标签3.标题 = “删除失败!”
.如果结束


发布日期:

所属分类: 易语言 标签: