易语言教程磁盘操作目录相关

文章目录[隐藏]

系统核心支持库---磁盘操作(目录)
新命令
1、取运行目录()---环境存取
2、创建目录()
3、取当前目录()
4、改变目录()
5、删除目录()
6、浏览文件夹()
调用格式: 〈文本型〉 浏览文件夹 (文本型 标题,[逻辑型 是否包含文件]) - 操作系统界面功能支持库->文件操作
英文名称:BrowseForFolder
打开一个对话框,浏览系统中存在的所有文件夹,返回被选定文件夹的路径名,如果未选中任何文件夹,则返回空文本。本命令为初级命令。
参数<1>的名称为“标题”,类型为“文本型(text)”。本参数提供显示在对话框上部的标题文本。
参数<2>的名称为“是否包含文件”,类型为“逻辑型(bool)”,可以被省略。本参数指定是否在浏览框中同时列出文件名。如果被省略,默认值为假。

操作系统需求: Windows

视频教程源码

.版本 2
.支持库 shell

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 取运行目录--取当前被执行的易程序文件所处的目录。本命令为初级命令。

标签1.标题 = 取运行目录 () ' C:\Users\zcp\Desktop\易语言教程-38

.子程序 _按钮2_被单击, , , 取当前目录--返回一个文本,用来代表当前的目录。如果失败,返回空文本。本命令为初级命令。

标签2.标题 = 取当前目录 ()

.子程序 _按钮3_被单击, , , 创建目录-- 创建一个新的目录。成功返回真,失败返回假。本命令为初级命令。

信息框 (创建目录 (“C:\Users\zcp\Desktop\易语言教程-38\temp\”), 0, , )

.子程序 _按钮4_被单击, , , 删除目录--删除一个存在的目录及其中的所有子目录和下属文件,请务必谨慎使用本命令。成功返回真,失败返回假。本命令为初级命令。

信息框 (删除目录 (“C:\Users\zcp\Desktop\易语言教程-38\temp\dm”), 0, , )

.子程序 _按钮5_被单击, , , 改变目录--改变当前的目录,但不会改变缺省驱动器位置。成功返回真,失败返回假。本命令为初级命令。
.局部变量 改变的目录名, 文本型

' 参数<1>的名称为“欲改变到的目录”,类型为“文本型(text)”。参数值指明哪个目录将成为新的缺省目录,可能会包含驱动器。如果没有指定驱动器,则在当前的驱动器上改变缺省目录。
改变前目录编辑框.内容 = 取当前目录 ()
改变的目录名 = 浏览文件夹 (“改变目录”, )
改变目录 (改变的目录名)
改变后目录编辑框.内容 = 取当前目录 ()
' 改变目录()后的参数()写要改变的目录文本,这个命令会目录文本自动保存在一个临时的变量中,以便“取当前目录()”来调用使用,
' “取当前目录()”返回“改变目录()”中的目录文本。


发布日期:

所属分类: 易语言 标签: