易语言打印九九乘法表

易语言教程变量循环首(九九乘法表)
易语言教程计次循环首(九九乘法表)

511遇见

九九乘法表源码

.版本 2
.子程序 九九
.局部变量 a, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 z, 整数型
.局部变量 jg, 文本型
.计次循环首 (9, i)
    加入成员 (a, i)
    .计次循环首 (取数组成员数 (a), z)
        .如果真 (取数组成员数 (a)1 且 a [z]1)
            编辑框1.加入文本 (#换行符)
        .如果真结束
        .如果 (取文本长度 (到文本 (a [z] × i))1)
            jg = “  ”
        .否则
            jg = “ ”
        .如果结束
        编辑框1.加入文本 (到文本 (a [z]) + “ × ” + 到文本 (i) + “ = ” + 到文本 (a [z] × i) + jg)
        处理事件 ()
    .计次循环尾 ()
.计次循环尾 ()

发布日期:

所属分类: 易语言 标签: