易语言教程寻找字节集和倒找字节集

寻找字节集

调用格式: 〈整数型〉 寻找字节集 (字节集 被搜寻的字节集,字节集 欲寻找的字节集,[整数型 起始搜寻位置]) - 系统核心支持库->字节集操作
英文名称:InBin
返回一字节集在另一字节集中最先出现的位置,位置值从 1 开始。如果未找到,返回 -1。本命令为初级命令。
参数<1>的名称为“被搜寻的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“欲寻找的字节集”,类型为“字节集(bin)”。
参数<3>的名称为“起始搜寻位置”,类型为“整数型(int)”,可以被省略。1为首位置,2为第2个位置,如此类推,如果被省略,则“寻找字节集”命令默认从首部开始,“倒找字节集”命令默认从尾部开始。

操作系统需求: Windows、Linux

倒找字节集

调用格式: 〈整数型〉 倒找字节集 (字节集 被搜寻的字节集,字节集 欲寻找的字节集,[整数型 起始搜寻位置]) - 系统核心支持库->字节集操作
英文名称:InBinRev
返回一字节集在另一字节集中最后出现的位置,位置值从 1 开始。如果未找到,返回 -1。本命令为初级命令。
参数<1>的名称为“被搜寻的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“欲寻找的字节集”,类型为“字节集(bin)”。
参数<3>的名称为“起始搜寻位置”,类型为“整数型(int)”,可以被省略。1为首位置,2为第2个位置,如此类推,如果被省略,则“寻找字节集”命令默认从首部开始,“倒找字节集”命令默认从尾部开始。

操作系统需求: Windows、Linux

视频教程源码

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 集_被寻找的字节集, 字节集
.程序集变量 集_欲寻找的字节集, 字节集

.子程序 __启动窗口_创建完毕

集_被寻找的字节集 = { 189, 241, 204, 236, 202, 199, 215, 230, 185, 250, 181, 218, 54, 56, 184, 246, 201, 250, 200, 213, 163, 172, 206, 210, 176, 174, 196, 227, 215, 230, 185, 250, 196, 184, 199, 215, 163, 161 }
集_欲寻找的字节集 = { 199 }
编辑框_被寻找的字节集.内容 = “189, 241, 204, 236, 202, 199, 215, 230, 185, 250, 181, 218, 54, 56, 184, 246, 201, 250, 200, 213, 163, 172, 206, 210, 176, 174, 196, 227, 215, 230, 185, 250, 196, 184, 199, 215, 163, 161”
编辑框_欲寻找的字节集.内容 = “199”

.子程序 _按钮1_被单击, , , 寻找字节集
.局部变量 局_位置, 整数型

局_位置 = 寻找字节集 (集_被寻找的字节集, 集_欲寻找的字节集, )
.判断开始 (局_位置 ≠ -1)
编辑框_位置.内容 = 到文本 (局_位置)
.默认
编辑框_位置.内容 = “没有找到字节集”
.判断结束

.子程序 _按钮2_被单击, , , 倒找字节集
.局部变量 局_位置, 整数型

局_位置 = 倒找字节集 (集_被寻找的字节集, 集_欲寻找的字节集, )
.判断开始 (局_位置 ≠ -1)
编辑框_位置.内容 = 到文本 (局_位置)
.默认
编辑框_位置.内容 = “没有找到字节集”
.判断结束

.子程序 _按钮3_被单击

结束 ()


发布日期:

所属分类: 易语言 标签: