易语言教程字节集替换和子字节集替换

字节集替换

调用格式: 〈字节集〉 字节集替换 (字节集 欲替换其部分的字节集,整数型 起始替换位置,整数型 替换长度,[字节集 用作替换的字节集]) - 系统核心支持库->字节集操作
英文名称:RpBin
将指定字节集的某一部分用其它的字节集替换,然后返回替换后的结果。本命令为初级命令。
参数<1>的名称为“欲替换其部分的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“起始替换位置”,类型为“整数型(int)”。替换的起始位置,1为首位置,2为第2个位置,如此类推。
参数<3>的名称为“替换长度”,类型为“整数型(int)”。
参数<4>的名称为“用作替换的字节集”,类型为“字节集(bin)”,可以被省略。如果本参数被省略,则删除字节集中的指定部分。

操作系统需求: Windows、Linux

子字节集替换

调用格式: 〈字节集〉 子字节集替换 (字节集 欲被替换的字节集,字节集 欲被替换的子字节集,[字节集 用作替换的子字节集],[整数型 进行替换的起始位置],[整数型 替换进行的次数]) - 系统核心支持库->字节集操作
英文名称:RpSubBin
返回一个字节集,该字节集中指定的子字节集已被替换成另一子字节集,并且替换发生的次数也是被指定的。本命令为初级命令。
参数<1>的名称为“欲被替换的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“欲被替换的子字节集”,类型为“字节集(bin)”。
参数<3>的名称为“用作替换的子字节集”,类型为“字节集(bin)”,可以被省略。如果省略本参数,则默认为空字节集。
参数<4>的名称为“进行替换的起始位置”,类型为“整数型(int)”,可以被省略。被替换子字节集的起始搜索位置。如果省略,默认从1开始。
参数<5>的名称为“替换进行的次数”,类型为“整数型(int)”,可以被省略。对子字节集进行替换的次数。如果省略,默认进行所有可能的替换。

操作系统需求: Windows、Linux

视频教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 字节集替换
.局部变量 欲替换的字节集, 字节集
.局部变量 用在替换的字节集, 字节集

欲替换的字节集 = { 1, 2, 3, 4, 5, 6 }
用在替换的字节集 = { 223 }
信息框 (“原字节集的长度为:” + 到文本 (取字节集长度 (欲替换的字节集)), 0, , )
欲替换的字节集 = 字节集替换 (欲替换的字节集, 5, 1, 用在替换的字节集)
信息框 (“替换后的字节集的长度为:” + 到文本 (取字节集长度 (欲替换的字节集)), 0, , )
调试输出 (欲替换的字节集)

.子程序 _按钮2_被单击, , , 子字节集替换
.局部变量 字节集变量, 字节集

字节集变量 = { 2, 4, 2, 4, 2, 4 }
字节集变量 = 子字节集替换 (字节集变量, { 2 }, { 9 }, 3, )
调试输出 (字节集变量)


发布日期:

所属分类: 易语言 标签: