26-软件安全验证检测MD5自校验

MD5自校验示意图:

511遇见

MD5自校验源码:

.版本 2
.支持库 dp1

.程序集 集_自校验

.子程序 自校验_md5, 逻辑型, 公开, 返回真校验成功,假说明文件被修改
.局部变量 局_运行目录, 文本型
.局部变量 局_执行文件名称, 文本型
.局部变量 局_字节集, 字节集
.局部变量 局_原MD5, 文本型
.局部变量 局_MD5, 文本型

局_运行目录 = 取运行目录 ()
局_执行文件名称 = 取执行文件名 ()
局_字节集 = 读入文件 (局_运行目录 + “\” + 局_执行文件名称)
局_原MD5 = 到文本 (取字节集右边 (局_字节集, 32))
_启动窗口.编辑框1.内容 = 局_原MD5
局_字节集 = 取字节集左边 (局_字节集, 取字节集长度 (局_字节集) - 32)
局_MD5 = 取数据摘要 (局_字节集)
_启动窗口.编辑框2.内容 = 局_MD5
.判断开始 (局_MD5 = 局_原MD5)
返回 (真)
.默认

.判断结束
返回 (假)

写入MD5源码:

.版本 2
.支持库 edroptarget
.支持库 dp1

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (取窗口句柄 ())

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型

编辑框1.内容 = 接收到的文件路径
编辑框2.内容 = 取数据摘要 (到字节集 (编辑框1.内容))

.子程序 _按钮1_被单击
.局部变量 局_文件号, 整数型
.局部变量 局_字节集, 字节集
.局部变量 局_MD5, 文本型

.判断开始 (文件是否存在 (编辑框1.内容))
局_文件号 = 打开文件 (编辑框1.内容, , )
局_字节集 = 读入字节集 (局_文件号, 取文件长度 (局_文件号))
局_MD5 = 取数据摘要 (局_字节集)
移到文件尾 (局_文件号)
写出字节集 (局_文件号, 到字节集 (局_MD5))
关闭文件 (局_文件号)
信息框 (“MD5写出成功!”, 0, , )

.默认

.判断结束


发布日期:

所属分类: 易语言 标签: