易语言教程取和设置屏幕分辨率

视频教程笔记

屏幕分辨率相关
一、系统处理
1、取屏幕宽度()
2、取屏幕高度()
二、应用接口支持库------窗口操作-----设置屏幕分辨率
 
设置屏幕分辨率()
 
三、SetRes 2.3 for Windows
 
帮助文档翻译:
====================================
 
  命令行修改屏幕分辨率,颜色质量,和刷新频率
 
 
================================================
 
使用
        SETRES hXXXX vXXXX [bXX] [fXX] [n]
 
hXXXX = 显示器长度(可选)最低640。
vXXXX = 显示器宽度(可选)最低480。
  bXX = 颜色质量【8, 16 24, 32】,可选。
  fXX = 以赫兹为频率单位刷新,比如 60, 75, 85。可选。
    n = 出错时不出现'Press a key'提示,可选。
 
举例
          SETRES h1024 v768               = 设置屏幕分辨率到 1024 x 768
          SETRES h800 v600 b24            = 设置屏幕分辨率到 800 x 60024位色。
          SETRES h1280 v1024 b32 f75      = 设置屏幕分辨率到 1280x1024,32位色,刷新频率75Hz
          SETRES h1024 v768 n             = 设置屏幕分辨率到 1024x768 并且出错时不出现'Press a key'提示

视频教程源码

.版本 2
.支持库 eAPI

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 取屏幕宽度

编辑框1.内容 = 到文本 (取屏幕宽度 ())

.子程序 _按钮2_被单击, , , 取屏幕高度

编辑框2.内容 = 到文本 (取屏幕高度 ())

.子程序 _按钮3_被单击, , , 设置屏幕分辨率

设置屏幕分辨率 (800, 600, 32, 60)

.子程序 _按钮4_被单击, , , 设置屏幕分辨率--窗口
.局部变量 a, 文本型

处理事件 ()
设置屏幕分辨率 (800, 600, 32, )
.计次循环首 (20, )
a = a + “111111111111111100000000000000000000011111111111111111111111000000000000000000000”
a = a + “0000000000000000111111111111111111111100000000000000000000001111111111111111111111”
.计次循环尾 ()
信息框 (a, 0, , )

.子程序 _按钮5_被单击

运行 (“SetRes.exe h800 v600 b32 f60”, 假, )

SetRes下载

http://www.softpedia.com/get/Multimedia/Video/Other-VIDEO-Tools/Ian-Sharpe-SetRes.shtml

视频链接


发布日期:

所属分类: 易语言 标签: