易语言DLL制作调用API序调用DLL的图片资源

定义lstrcpynA

.版本 2
 
.DLL命令 lstrcpynZ, 整数型, "kernel32", "lstrcpynA", , 可以参数自定义
    .参数 lpString1, 字节集, , 0
    .参数 lpString2, 字节集, , 0
    .参数 iMaxLength, 整数型, , 0

DLL图片调用函数

.版本 2
 
.子程序 getlogo, 整数型, 公开
 
返回 (lstrcpynZ (#logo, #logo, 0))
 
.子程序 getico, 整数型, 公开
 
返回 (lstrcpynZ (#ico, #ico, 0))

DLL图片资源

.版本 2
 
.图片 logo
.图片 ico

易语言调用DLL图片资源源码:

定义DLL

.版本 2
 
.DLL命令 getlogo, 整数型, "dll.dll", "getlogo"
 
.DLL命令 getico, 整数型, "dll.dll", "getico"

调用

.版本 2
 
.子程序 _按钮1_被单击
.局部变量 a, 整数型
.局部变量 l, 整数型
.局部变量 pic, 字节集
 
' 易语言字节集变量的地址是首字的地址
' 首字符前4个字节是其长度
a = getlogo ()
l = 取字节集数据 (指针到字节集 (a - 4, 4), #整数型, )
 
pic = 指针到字节集 (a, l)
图片框1.图片 = pic
 
.子程序 _按钮2_被单击
.局部变量 a, 整数型
.局部变量 l, 整数型
.局部变量 pic, 字节集
 
' 易语言字节集变量的地址是首字的地址
' 首字符前4个字节是其长度
a = getico ()
l = 取字节集数据 (指针到字节集 (a - 4, 4), #整数型, )
 
pic = 指针到字节集 (a, l)
图标 = pic

教程获取下载:


发布日期:

所属分类: 易语言 标签: