易语言汇编主程序和DLL交换数据自定义数据数组

DLL自定义数组型数据类型

.版本 2
 
.数据类型 遇见数据
    .成员 A, 短整数型
    .成员 B, 整数型
    .成员 C, 长整数型
    .成员 D, 逻辑型
    .成员 E, 文本型
    .成员 F, 日期时间型

DLL自定义数据数组源码:

.版本 2
 
.子程序 dll6, , 公开, 6-自定义数据类型数组
.参数 保存地址, 整数型
.局部变量 A, 遇见数据, , "0"
.局部变量 n, 整数型
 
.计次循环首 (10, n)
    ' 因为初始定义的是0,这里必须重定义数组,且为真
    重定义数组 (A, 真, n)
    A [n].A = 10 × n
    A [n].B = 1110 × n
    A [n].C = 100000000 × n
    A [n].D = 真
    A [n].E = “自数组--” + 到文本 (n)
    A [n].F = 取现行时间 ()
.计次循环尾 ()
交换变量数据_地址交地址ASM (取变量地址_ASM数组 (A), 保存地址)

主程序动态调用自定义数据数组

.版本 2
 
.子程序 _按钮6_被单击, , , 6-自定义数据类型数组
.局部变量 A, 遇见数据, , "0"
.局部变量 地址, 整数型
.局部变量 命令地址, 整数型
.局部变量 参数数据地址, 整数型, , "1"
.局部变量 i, 整数型
.局部变量 txt, 文本型
 
' 1-获取变量地址
地址 = 取变量地址_ASM数组 (A)
' 2-获取函数命令地址
命令地址 = 取DLL命令地址_ASM (dll路径, “dll6”)
' 调用这个函数方法,第二个参数 参数数据地址 是数组,必须转换一下
参数数据地址 [1] = 地址
' 4-调用这个命令方法
调用命令_ASM (命令地址, 参数数据地址, )
.计次循环首 (取数组成员数 (A), i)
    txt = txt + “序号” + 到文本 (i) + “ ” + 到文本 (A [i].A) + “;” + 到文本 (A [i].B) + “;” + 到文本 (A [i].C) + “;” + 到文本 (A [i].D) + “;” + A [i].E + “;” + 到文本 (A [i].F) + “;” + #换行符
.计次循环尾 ()
编辑框1.内容 = txt

主程序静态调用自定义数据数组

.版本 2
 
.子程序 _按钮6_被单击, , , 6-自定义数据类型数组
.局部变量 地址, 整数型
.局部变量 A, 遇见数据, , "0"
.局部变量 i, 整数型
.局部变量 txt, 文本型
 
地址 = 取变量地址_ASM数组 (A)
dll6 (地址)
.计次循环首 (取数组成员数 (A), i)
    txt = txt + “序号” + 到文本 (i) + “ ” + 到文本 (A [i].A) + “;” + 到文本 (A [i].B) + “;” + 到文本 (A [i].C) + “;” + 到文本 (A [i].D) + “;” + A [i].E + “;” + 到文本 (A [i].F) + “;” + #换行符
.计次循环尾 ()
编辑框1.内容 = txt

教程下载:


发布日期:

所属分类: 易语言 标签: