CreateRemoteThread远程线程注入dll到游戏-2

DLL源码

.版本 2
.支持库 EThread
.支持库 eAPI
 
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
 
启动线程 (&th, , )
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
 
.子程序 th, , 公开
.局部变量 ret
 
载入 (窗口1, , 真)
ret = 信息框 (“所在进程ID是:” + 到文本 (进程_取自进程ID ()) + #换行符 + “ 确定 键进程 辅助窗口,取消 键 关闭进程!”, #确认取消钮, “进程名:” + 进程_ID取进程名 (进程_取自进程ID ()), )
.判断开始 (ret = #确认钮)
    启动线程 (&辅助, , )
.判断 (ret = #取消钮)
    FreeLibrary (GetModuleHandleA (“thook.dll”))
    结束 ()
.默认
 
.判断结束
 
 
.子程序 辅助
 
.计次循环首 (20, )
    模拟按键 (#F4键, , )
    程序_延时 (500, )
.计次循环尾 ()

视频教程下载:

链接:https://pan.baidu.com/s/158ikKVjIwaoF4438MG4fhA

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 后端 标签: