易语言DLL制作调用及汇编主程序和DLL里类数据交换

DLL里的类模块

.版本 2
 
.程序集 类dll, , 公开, DLL
 
.子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用
.子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用
.子程序 mybox, , 公开
 
信息框 (“我是DLL类里的信息框”, 0, “DLL-1-类”, )
 
.子程序 add, , 公开
.参数 a
.参数 b
 
信息框 (a + b, 0, , )

DLL源码:

.版本 2
 
.子程序 dll, , 公开
.参数 保存地址, 整数型
.局部变量 A, 类dll
 
交换变量数据_变量交地址ASM (A, 保存地址)

主程序动态调用DLL里的类

.版本 2
 
.子程序 dll, , 公开
.参数 保存地址, 整数型
.局部变量 A, 类dll
 
交换变量数据_变量交地址ASM (A, 保存地址)

易语言主程序静态调用DLL里的类

.版本 2
 
.子程序 dll, , 公开
.参数 保存地址, 整数型
.局部变量 A, 类dll
 
交换变量数据_变量交地址ASM (A, 保存地址)

教程下载:


发布日期:

所属分类: 易语言 标签: