易语言实现全局键盘钩子屏蔽任意按键

安装键盘钩子

键盘钩子 = SetWindowsHookExA (13, &键盘钩子, GetModuleHandleA (0), 0)

键盘钩子回调函数

.版本 2
 
.子程序 键盘钩子, 整数型
.参数 ncode, 整数型, , 钩子子程用来确定如何处理消息的代码
.参数 wParam, 整数型, , 虚拟键码
.参数 lParam, 整数型, , 指向KBDLLHOOKSTRUCT结构的指针
.局部变量 按键信息, KBDLLHOOKSTRUCT
 
CopyMemory (按键信息, lParam, 28)
.如果真 (ncode = 0)
    ' A键是65----90
    .如果真 (按键信息.vkCode ≥ 65 且 按键信息.vkCode ≤ 90)
        返回 (1)
    .如果真结束
 
    返回 (0)
.如果真结束
 
返回 (CallNextHookEx (键盘钩子, ncode, wParam, lParam))

键盘钩子结构体

.版本 2
 
.数据类型 KBDLLHOOKSTRUCT
    .成员 vkCode, 整数型, , , 指定虚拟键值
    .成员 scanCode, 整数型, , , 指定键的硬件扫描码。
    .成员 flags, 整数型, , , 事件注入标志
    .成员 time, 整数型, , , 事件注入时间
    .成员 dwExtraInfo, 整数型, , , 额外的信息

卸载键盘钩子

UnhookWindowsHookEx (键盘钩子)

教程获取下载:


发布日期:

所属分类: 易语言 标签: