易语言教程字节集操作分割字节集

分割字节集

调用格式: 〈字节集数组〉 分割字节集 (字节集 待分割字节集,[字节集 用作分割的字节集],[整数型 要返回的子字节集数目]) - 系统核心支持库->字节集操作
英文名称:SplitBin
将指定字节集进行分割,返回分割后的一维字节集数组。本命令为初级命令。
参数<1>的名称为“待分割字节集”,类型为“字节集(bin)”。如果参数值是一个长度为零的字节集,则返回一个空数组,即没有任何成员的数组。
参数<2>的名称为“用作分割的字节集”,类型为“字节集(bin)”,可以被省略。用于标识子字节集边界。本参数如果被省略,则默认使用字节 0 作为分隔符。
参数<3>的名称为“要返回的子字节集数目”,类型为“整数型(int)”,可以被省略。如果被省略,则默认返回所有的子字节集。

操作系统需求: Windows、Linux

视频教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 分割字节集 {163,172}
.局部变量 待分割的字节集, 字节集
.局部变量 返回字节集数组, 字节集, , "0"
.局部变量 t, 整数型
.局部变量 i, 整数型

待分割的字节集 = 到字节集 (编辑框1.内容)
返回字节集数组 = 分割字节集 (待分割的字节集, , )

t = 取数组成员数 (返回字节集数组)
.计次循环首 (t, i)
调试输出 (返回字节集数组 [i])
编辑框2.加入文本 (到文本 (返回字节集数组 [i]) + #换行符)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: