易语言通过全局键盘钩子实现键盘记录

键盘钩子回调函数

.版本 2
.支持库 spec
.支持库 eAPI
 
.子程序 键盘钩子回调函数, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型, , 按键状态
.参数 参数三, 整数型, , 结构指针
.局部变量 键值, 整数型
 
' 不使用键盘结构体如何获取键值
' 指针到字节集后里的参数二,1---,只取 1 位,因为整数在字节集里的占1' 把指针就转换成了 键值
' 3 s是整数型
键值 = 取字节集数据 (指针到字节集 (参数三, 1), 3, )
' 256是按下
' 257是弹起
.判断开始 (参数二 = 256)
    调试输出 (键值)
    ' 判断按下A键了--就可以启动游戏里的技能快捷键
    '26个字母键操作
    .判断开始 (键值 ≥ 65 且 键值 ≤ 90)
        ' 取键盘指示灯状态’
        .判断开始 (取键盘指示灯状态 (1) = 真)
            编辑框1.加入文本 (字符 (键值))
            ' 大写字母比对应的小写字母少 32
        .默认
            编辑框2.加入文本 (字符 (键值 + 32))
        .判断结束
 
    .默认
 
    .判断结束
 
    ' 按键弹起
.判断 (参数二 = 257)
 
.默认
 
.判断结束
 
返回 (CallNextHookEx (键盘钩子, 参数一, 参数二, 参数三))

安装钩子

键盘钩子 = SetWindowsHookExA (13, &键盘钩子回调函数, GetModuleHandleA (0), 0)

511遇见易语言DLL制作调用及hook注入

资源教程交流①群:521068947


发布日期:

所属分类: 易语言 标签: