易语言采用标签反馈事件显示隐藏窗口的四种方法

多线程控制大漠foobar在游戏中输出辅助信息

注册热键

声明程序集变量Home
home = 注册热键 (_启动窗口.取窗口句柄 (), 标签1.取窗口句柄 (), 0, #Home键)
注意第三个参数,0就是单个按键实现显示隐藏,1就是Ctrl+注册的热键,

标签反馈事件

最后第四种方法是借助窗口的一个按键的标题的变化来实现的。源码采用了注释,复制后需要清除。

.版本 2
 
.子程序 _标签1_反馈事件, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
 
' 1、最简单
.' 如果真 (参数一 = home)
    ' _启动窗口.可视 = 取反 (_启动窗口.可视)
.如果真结束
 
' 2、标准
 
.如果真 (参数一 = home)
    _启动窗口.可视 = 取反 (_启动窗口.可视)
    _启动窗口.位置 = 选择 (_启动窗口.可视, 0, 2)
.如果真结束
 
' 3、API
.' 如果真 (参数一 = home)
    ' _启动窗口.可视 = 取反 (ShowWindowAsync (_启动窗口.取窗口句柄 (), 选择 (_启动窗口.可视, 0, 1)))
    ' _启动窗口.位置 = 选择 (_启动窗口.可视, 0, 2)
.如果真结束
 
' 4、借助按键
.' 如果真 (按钮1.标题 = “隐藏”)
    ' ' _启动窗口.可视 = 真
    ' ' ShowWindowAsync (_启动窗口.取窗口句柄 (), 0)
    ' ' 窗口_显示隐藏 (_启动窗口.取窗口句柄 (),)
    ' ShowWindowAsyncA (_启动窗口.取窗口句柄 (), 假)
    ' 按钮1.标题 = “显示”
    ' 返回 ()
.如果真结束
.' 如果真 (按钮1.标题 = “显示”)
    ' ' _启动窗口.可视 = 假
    ' ' ShowWindowAsync (_启动窗口.取窗口句柄 (), 1)
    ' ' 窗口_显示隐藏 (_启动窗口.取窗口句柄 (),)
    ' ShowWindowAsyncA (_启动窗口.取窗口句柄 (), 真)
 
    ' 按钮1.标题 = “隐藏”
    ' 返回 ()
.如果真结束

发布日期:

所属分类: 易语言 标签: