易语言教程文本替换和子文本替换

文章目录[隐藏]

视频课程源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 文本替换

' 参数<4>的名称为“用作替换的文本”,类型为“文本型(text)”,可以被省略。如果本参数被省略,则删除文本中的指定部分。
编辑框5.内容 = 文本替换 (编辑框1.内容, 到整数 (编辑框2.内容), 到整数 (编辑框3.内容), 编辑框4.内容)

.子程序 _按钮2_被单击, , , 子文本替换

' 文本替换 (, , , )
' 返回一个文本,该文本中指定的子文本已被替换成另一子文本,并且替换发生的次数也是被指定的。本命令为初级命令。
' 参数<1>的名称为“欲被替换的文本”,类型为“文本型(text)”。
' 参数<2>的名称为“欲被替换的子文本”,类型为“文本型(text)”。
' 参数<3>的名称为“用作替换的子文本”,类型为“文本型(text)”,可以被省略。如果本参数被省略,默认为空文本。
' 参数<4>的名称为“进行替换的起始位置”,类型为“整数型(int)”,可以被省略。参数值指定被替换子文本的起始搜索位置。如果省略,默认从 1 开始。
' 参数<5>的名称为“替换进行的次数”,类型为“整数型(int)”,可以被省略。参数值指定对子文本进行替换的次数。如果省略,默认进行所有可能的替换。
' 参数<6>的名称为“是否区分大小写”,类型为“逻辑型(bool)”,初始值为“真”。为真区分大小写,为假不区分。
' 子文本替换 (, , , , , 真)

.子程序 高级替换, 文本型
.参数 原文本, 文本型
.参数 被替换掉的文本, 文本型
.参数 用来替换的文本, 文本型
.局部变量 文本内容, 文本型
.局部变量 替换位置, 整数型

文本内容 = 原文本
替换位置 = 寻找文本 (文本内容, 被替换掉的文本, , 假)
.判断循环首 (替换位置 > 0)
文本内容 = 子文本替换 (文本内容, 被替换掉的文本, 用来替换的文本, 替换位置, 1, 真)
替换位置 = 寻找文本 (文本内容, 被替换掉的文本, 替换位置, 假)
.判断循环尾 ()
返回 (文本内容)

.子程序 _按钮3_被单击, , , 高级替换

编辑框4.内容 = 高级替换 (编辑框1.内容, 编辑框2.内容, 编辑框3.内容)


发布日期:

所属分类: 易语言 标签: