易语言教程分割文本

教程全部源码

.版本 2
.支持库 spec
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 分割文本
.局部变量 返回文本数组, 文本型, , "0"
.局部变量 n, 整数型

列表框1.清空 ()
返回文本数组 = 分割文本 (编辑框1.内容, “0”, )
调试输出 (返回文本数组)
.计次循环首 (取数组成员数 (返回文本数组), n)
列表框1.加入项目 (返回文本数组 [n], )
.计次循环尾 ()

.子程序 _按钮2_被单击, , , 读入账号
.局部变量 读入的文本, 文本型
.局部变量 返回文本数组, 文本型, , "0"
.局部变量 i, 整数型

读入的文本 = 到文本 (读入文件 (取运行目录 () + “\账号.txt”))
返回文本数组 = 分割文本 (读入的文本, #换行符, )
.计次循环首 (取数组成员数 (返回文本数组), i)
列表框1.加入项目 (返回文本数组 [i], )
.计次循环尾 ()

.子程序 _按钮3_被单击, , , 读入账号密码
.局部变量 文本, 文本型
.局部变量 文本数组, 文本型, , "0"
.局部变量 文本数组2, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 账号, 文本型
.局部变量 密码, 文本型
.局部变量 索引

超级列表框1.全部删除 ()
文本 = 到文本 (读入文件 (取运行目录 () + “\账号密码.txt”))
文本数组 = 分割文本 (文本, #换行符, )
.计次循环首 (取数组成员数 (文本数组), i)
文本数组2 = 分割文本 (文本数组 [i], “|”, )
账号 = 文本数组2 [1]
密码 = 文本数组2 [2]
调试输出 (账号)
调试输出 (密码)
索引 = 超级列表框1.插入表项 (, , , , , )
超级列表框1.置标题 (索引, 0, 到文本 (i))
超级列表框1.置标题 (索引, 1, 账号)
超级列表框1.置标题 (索引, 2, 密码)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: