易语言列表框防止项目重复加入列表框

视频教程截图

511遇见

易语言列表框防止项目重复加入列表框视频教程源码:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

列表框1.现行选中项 = 0
皮肤_加载 (1)

.子程序 _按钮1_被单击

列表框1.加入项目 (编辑框1.内容, )
编辑框1.内容 = “”

.子程序 _按钮2_被单击, , , 不重复加入-1

.如果 (列表框1.选择 (编辑框1.内容) = -1)
列表框1.加入项目 (编辑框1.内容, )
信息框 (“添加成功!”, 0, , )
.否则
信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )

.如果结束

.子程序 _按钮3_被单击, , , 不重复加入-2

.如果 (SendMessageA (列表框1.取窗口句柄 (), 399, 0, 编辑框1.内容) = -1)
列表框1.加入项目 (编辑框1.内容, )
信息框 (“添加成功!”, 0, , )
.否则
信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )

.如果结束

.子程序 _按钮4_被单击, , , 不重复加入-3
.局部变量 i, 整数型
.局部变量 重复, 逻辑型

.计次循环首 (列表框1.取项目数 (), i)
.如果真 (列表框1.取项目文本 (i - 1) = 编辑框1.内容)
重复 = 真
跳出循环 ()
.如果真结束
重复 = 假
.计次循环尾 ()

.如果 (重复 = 假)
列表框1.加入项目 (编辑框1.内容, )
编辑框1.内容 = “”
信息框 (“添加成功!”, 0, , )
.否则
信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 16, , )
.如果结束

教程下载:


发布日期:

所属分类: 易语言 标签: