易语言大漠模块制作按键按下(住)指定的虚拟键码

模块源码

.版本 2

.子程序 KeyDown, 整数型, 公开, 按住指定的虚拟键码(返回值:0失败,1成功)
.参数 vk_code, 整数型, , vk_code 整形数:虚拟按键码

返回 (obj.数值方法 (“KeyDown”, vk_code))

.子程序 KeyUp, 整数型, 公开, 弹起来虚拟键vk_code(返回值:0失败,1成功)
.参数 vk_code, 整数型, , vk_code 整形数:虚拟按键码

返回 (obj.数值方法 (“KeyUp”, vk_code))

.子程序 KeyDownChar, 整数型, 公开, 按住指定的虚拟键码(返回值:0失败,1成功)
.参数 key_str, 文本型, , key_str 字符串: 字符串描述的键码. 大小写无所谓.

返回 (obj.数值方法 (“KeyDownChar”, key_str))

.子程序 KeyUpChar, 整数型, 公开, 弹起来虚拟键key_str(返回值:0失败,1成功)
.参数 key_str, 文本型, , 字符串: 字符串描述的键码. 大小写无所谓. 点这里查看具体对应关系.

返回 (obj.数值方法 (“KeyUpChar”, key_str))

.子程序 KeyPress, 整数型, 公开, 按下指定的虚拟键码(返回值:0失败,1成功)
.参数 vk_code, 整数型, , vk_code 整形数:虚拟按键码

返回 (obj.数值方法 (“KeyPress”, vk_code))

.子程序 KeyPressChar, 整数型, 公开, 按下指定的虚拟键码(返回值:0失败,1成功)
.参数 key_str, 文本型, , key_str 字符串: 字符串描述的键码. 大小写无所谓. 点这里查看具体对应关系.

返回 (obj.数值方法 (“KeyPressChar”, key_str))

.子程序 KeyPressStr, 整数型, 公开, 根据指定的字符串序列,依次按顺序按下其中的字符.(返回值:0失败,1成功)
.参数 key_str, 文本型, , key_str 字符串: 需要按下的字符串序列. 比如"1234","abcd","7389,1462"等.
.参数 delay, 整数型, , delay 整形数: 每按下一个按键,需要延时多久. 单位毫秒.这个值越大,按的速度越慢。

返回 (obj.数值方法 (“KeyPressStr”, key_str, delay))

例程源码

.版本 2
 
.子程序 _按钮2_被单击, , , KeyPress
 
插件初始化 ()
SetPath (取运行目录 ())
绑定 ()
' KeyPress (115)
KeyPressChar (“F4”)
UnBindWindow ()
 
.子程序 绑定
.局部变量 hwnd, 整数型
 
hwnd = FindWindow (, “剑侠情缘·网络版”)
延时 (1000)
MoveWindow (hwnd, -10, -10)
SetAero (0)
SetWindowState (hwnd, 1)
BindWindow (hwnd, “dx2”, “dx”, “windows”, 0)
延时 (1500)

视频链接


发布日期:

所属分类: 易语言 标签: