API控制组合框高度宽度居中下拉方向

教程截图

511遇见

API控制组合框高度宽度居中下拉方向视频教程源码:

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 hwnd
.程序集变量 程_子程序, 子程序指针

.子程序 __启动窗口_创建完毕

置随机数种子 ()
.计次循环首 (10, )
组合框1.加入项目 (到文本 (取随机数 (111111111, 999999999)), )
.计次循环尾 ()
hwnd = 组合框1.取窗口句柄 ()

.子程序 _按钮1_被单击

组合框1.发送信息 (339, -1, 到整数 (编辑框1.内容))

.子程序 _按钮2_被单击

PostMessageA (hwnd, 339, -1, 到整数 (编辑框1.内容))

.子程序 _按钮3_被单击

PostMessageA (hwnd, 339, 0, 到整数 (编辑框1.内容) - 6)

.子程序 _按钮4_被单击

PostMessageA (hwnd, 352, 到整数 (编辑框1.内容), 0)

.子程序 _按钮5_被单击

SendMessageA (hwnd, 335, 1, 0)

.子程序 _按钮6_被单击

SendMessageA (hwnd, 335, 0, 0)

.子程序 _按钮7_被单击
.局部变量 hEdit
.局部变量 style

hEdit = FindWindowExA (hwnd, 0, “Edit”, 字符 (0))
style = GetWindowLongA (hEdit, #GWL_STYLE)
style = 位或 (style, #ES_CENTER)
SetWindowLongA (hEdit, #GWL_STYLE, style)

.子程序 _按钮8_被单击, , , 向上弹出下拉框

程_子程序 = SetWindowLongAA (组合框1.取窗口句柄 (), -4, &窗口消息)
SendMessageA (组合框1.取窗口句柄 (), 335, 1, 0)
SetWindowLongAA (组合框1.取窗口句柄 (), -4, 程_子程序)

.子程序 窗口消息, 整数型
.参数 窗口句柄
.参数 消息
.参数 参数1
.参数 参数2
.局部变量 局_列表框, RECT
.局部变量 局_组合框, RECT

.如果真 (消息 = 308)
GetWindowRect (参数2, 局_列表框)
GetWindowRect (窗口句柄, 局_组合框)
SetWindowPos (参数2, 0, 局_列表框.Left, 局_组合框.Top - (局_列表框.Bottom - 局_列表框.Top), 局_列表框.Right - 局_列表框.Left, 局_列表框.Bottom - 局_列表框.Top, 0)

.如果真结束

返回 (CallWindowProcA (程_子程序, 窗口句柄, 消息, 参数1, 参数2))

教程下载:


发布日期:

所属分类: 易语言 标签: