易语言多线程大漠多线程-37大漠多线程模板-7脚本主副线程

大漠多线程主副线程

.版本 2
 
.子程序 脚本副线程, , , 监控线程
.参数 序号, 整数型
.局部变量 dm, dmsoft
.局部变量 dm_ret, 整数型
.局部变量 死循环, 逻辑型
.局部变量 任务完成, 文本型
 
' 要把大漠插件接口初始化为MAT线程模型
CoInitializeEx (0, 0)
线程信息 [序号].线程状态 = #线程状态_正在运行
 
多线程_异步通知UI (#通知类型_更新, 序号)
' 创建对象
线程信息 [序号].dm.创建 ()
dm = 线程信息 [序号].dm
 
.如果真 (dm.Ver () = “”)
    日志输出 (“大漠对象创建失败”)
    设置异常 (序号, “对象创建失败”)
 
    返回 ()
.如果真结束
 
' 开启全局字库
' dm.EnableShareDict ()
' 设置全局路径
dm.SetPath (“c:\test”)
' 开始绑定游戏窗口,根据自己的游戏换绑定方式
dm_ret = dm.BindWindowEx (线程信息 [序号].窗口句柄, “normal”, “normal”, “dx”, “dx.public.anti.api|dx.public.disable.window.show, 0)
.如果真 (dm_ret ≠ 1)
    日志输出 (“主:绑定失败,错误码:” + 到文本 (dm.GetLastError ()))
    ' 通知主线程进行结束操作(释放资源)
    设置异常 (序号, “绑定失败:副”)
    返回 ()
.如果真结束
 
死循环 = 真
.判断循环首 (死循环)
    ' 可用来检测脚本的异常情况,比如,掉线,目标窗口关闭,
    检测异常 (序号)
    脚本延时 (序号, 1000)
 
.判断循环尾 ()
 
 
.子程序 做任务
.参数 序号
.局部变量 dm, dmsoft
 
dm = 线程信息 [序号].dm
dm.KeyPressChar (“D”)
脚本延时 (序号, 1000)
 
 
.子程序 脚本延时
.参数 序号
.参数 时间
 
延时 (时间)


发布日期:

所属分类: 易语言 标签: