大漠多账号循环登录任务自动切换模板-8判断启动登录情况

教程源码:

.版本 2
.子程序 是否登录成功, 逻辑型, , 登录成功返回真
.局部变量 x
.局部变量 y

dm.FindPic (0, 0, 2000, 2000, “登录成功.bmp”, “000000”, 0.9, 0, x, y)
.判断开始 (x > 0 且 y > 0)
返回 (真)
.默认
返回 (假)
.判断结束

.子程序 是否启动成功, 逻辑型, , 启动成功返回真
.局部变量 x
.局部变量 y

dm.FindPic (0, 0, 2000, 2000, “开始.bmp”, “000000”, 0.9, 0, x, y)
.判断开始 (x > 0 且 y > 0)
返回 (真)
.默认
返回 (假)
.判断结束

.子程序 登录游戏
.判断开始 (运行状态 > 0)
.判断开始 (是否启动成功 () = 真)
.判断开始 (是否登录成功 () = 真)
监控反馈 (“进入游戏成功”)
超级延时 (3000, )
调处循环()

.默认

.判断结束
.默认

.判断结束

.默认

.判断结束
.子程序 模拟打怪

.判断开始 (运行状态 > 0)
.判断开始 (是否登录成功 () = 真)
.计次循环首 (10, )
dm.KeyPress (115)
超级延时 (1000, )
.计次循环尾 ()

.默认

.判断结束
.默认

.判断结束
.子程序 退出游戏

.判断开始 (运行状态 > 0)
系统处理事件 ()
dm.MoveTo (646, 581)
超级延时 (300, )
dm.LeftClick ()
超级延时 (2000, )
dm.MoveTo (380, 225)
超级延时 (300, )
dm.LeftClick ()
超级延时 (300, )

.默认


发布日期:

所属分类: 易语言 标签: