大漠多线程循环任务自动切换模板-7自动切换账号

多窗口自动切换账号源码:

.版本 2
.支持库 iext
 
.子程序 切换账号
.参数 索引
.局部变量 text, 文本型, , "0"
.局部变量 temp, 文本型, , "0"
.局部变量 n, 整数型
 
' 8是全部账号,7完成次数,6窗口账号数量,5当前完成的次数
超级延时 (100, )
text = 分割文本 (窗口列表.取标题 (索引 - 1, 8), “|”, )
超级延时 (100, )
' 判断完成的次数和每个窗口内的账号总数比较
.判断开始 (到整数 (窗口列表.取标题 (索引 - 1, 7)) < 取数组成员数 (text))
    超级延时 (500, )
    temp = 分割文本 (text [到整数 (窗口列表.取标题 (索引 - 1, 7))1],----, )
    ' 采用计次循环把账号密码分开
    .计次循环首 (取数组成员数 (temp), n)
 
        系统处理事件 ()
        ' 把账号放到 1列,密码放到 2 列
        窗口列表.置标题 (索引 - 1, n, temp [n])
 
    .计次循环尾 ()
 
.默认


发布日期:

所属分类: 易语言 标签: