易语言教程列表框属性方法

视频教程截图

511遇见

易语言教程列表框视频教程源码:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

信息框 (列表框1.取项目文本 (列表框1.现行选中项), #信息图标, , )

.子程序 _按钮2_被单击

信息框 (列表框1.取项目文本 (到整数 (编辑框1.内容)), #信息图标, , )

.子程序 _按钮3_被单击

列表框1.置项目文本 (列表框1.现行选中项, 编辑框1.内容)

.子程序 _按钮4_被单击
.局部变量 项目索引

项目索引 = 列表框1.加入项目 (编辑框1.内容, )
列表框1.现行选中项 = 项目索引

.子程序 _按钮5_被单击
.局部变量 项目索引, 整数型

项目索引 = 列表框1.插入项目 (到整数 (编辑框1.内容), 编辑框2.内容, )
列表框1.现行选中项 = 项目索引

.子程序 _按钮6_被单击
.局部变量 bool, 逻辑型

bool = 列表框1.是否被选择 (到整数 (编辑框1.内容))
.如果 (bool)
信息框 (“被选择”, 0, , )
.否则
信息框 (“没有选择”, 0, , )
.如果结束

.子程序 _按钮7_被单击
.局部变量 项目数组, 整数型, , "0"
.局部变量 选择数量
.局部变量 索引文本, 文本型
.局部变量 项目文本, 文本型
.局部变量 n, 整数型

项目数组 = 列表框1.取所有被选择项目 ()
选择数量 = 取数组成员数 (项目数组)
.如果真 (选择数量 = 0)
信息框 (“请选择项目”, 0, , )
返回 ()
.如果真结束

.计次循环首 (选择数量, n)

索引文本 = 索引文本 + #换行符 + 到文本 (项目数组 [n])

项目文本 = 项目文本 + #换行符 + 列表框1.取项目文本 (项目数组 [n])

.计次循环尾 ()

信息框 (“被选中的项目文本:” + 索引文本 + 项目文本, 0, , )

教程下载:


发布日期:

所属分类: 易语言 标签: