易语言屏蔽WIN、ALT+TAB、CTRL+ESC键的低级键盘钩子

回调函数:
LRESULT CALLBACK LowLevelKeyboardProc(int nCode, WPARAM wParam, LPARAM lParam)
{
BOOL fEatKeystroke = FALSE;
PKBDLLHOOKSTRUCT p = NULL;

if (nCode == HC_ACTION)
{
p = (PKBDLLHOOKSTRUCT) lParam;
switch (wParam)
{
case WM_KEYDOWN:
// Backdoor to user information
if (p->vkCode == VK_F8)
{
::MessageBox(NULL,"Let's make things better and better!/n","HQ Tech",MB_OK);
break;
}
case WM_SYSKEYDOWN:
case WM_KEYUP:
case WM_SYSKEYUP:
fEatKeystroke = (p->vkCode == VK_LWIN) || (p->vkCode == VK_RWIN) || // 屏蔽Win
// 屏蔽Alt+Tab
((p->vkCode == VK_TAB) && ((p->flags & LLKHF_ALTDOWN) != 0)) ||
// 屏蔽Alt+Esc
((p->vkCode == VK_ESCAPE) && ((p->flags & LLKHF_ALTDOWN) != 0)) ||
// 屏蔽Ctrl+Esc
((p->vkCode == VK_ESCAPE) && ((GetKeyState(VK_CONTROL) & 0x8000) != 0));
break;
default:
break;
}
}

return (fEatKeystroke ? TRUE : CallNextHookEx(glhHook,nCode,wParam,lParam));
}

安装及卸载钩子:

void _stdcall StartKeyMask()
{
// 安装钩子
glhHook = SetWindowsHookEx(WH_KEYBOARD_LL,LowLevelKeyboardProc,glhInstance,0);
}

void _stdcall StopKeyMask()
{
// 卸载钩子
if (glhHook!=NULL)
UnhookWindowsHookEx(glhHook);
}

易语言实现源码:

.版本 2
.支持库 spec

' 实现模拟按键代码
.如果真 (按键信息.vkCode = #Tab键 且 位与 (按键信息.flags, 32) ≠ 0)
' 屏蔽ALT+TAB
调试输出 (“屏蔽ALT+TAB”)
返回 (1)
.如果真结束
.如果真 (按键信息.vkCode = #Esc键 且 位与 (按键信息.flags, 32) ≠ 0)
' 屏蔽ALT+ESC
调试输出 (“屏蔽ALT+ESC”)
返回 (1)
.如果真结束
.如果真 (按键信息.vkCode = #F4键 且 位与 (按键信息.flags, 32) ≠ 0)
' 屏蔽ALT+F4
调试输出 (“屏蔽ALT+F4”)
返回 (1)
.如果真结束
.如果真 (按键信息.vkCode = #Esc键 且 位与 (GetKeyState (17), 32768) ≠ 0)
' 屏蔽CTRL+ESC
调试输出 (“ 屏蔽CTRL+ESC”)
返回 (1)
.如果真结束
.如果真 (按键信息.vkCode = 91 或 按键信息.vkCode = 92 或 按键信息.vkCode = 93)
' 左右Win 和徽标键
调试输出 (“ 左右Win 和徽标键”)
返回 (1)
.如果真结束
.如果真 (按键信息.vkCode = #Ctrl键 且 位与 (按键信息.flags, 32) ≠ 0)
调试输出 (1)

返回 (1)


发布日期:

所属分类: 易语言 标签: