易语言API HooK类模块封装与调用

511遇见

安装钩子

.版本 2
a.安装Hook (“User32.dll”, “MessageBoxA”, 到整数 (&myMessageBoxA))
a.开始Hook ()

钩子myMessageBoxA

  1. .版本 2
  2.  
  3. .子程序 myMessageBoxA, 整数型
  4. .参数 hWnd, 整数型, , 窗口句柄
  5. .参数 lpText, 文本型, , 提示内容
  6. .参数 lpCaption, 文本型, , 提示标题
  7. .参数 uType, 整数型, , 提示图标和按钮类型
  8.  
  9. ' 先停止HOOK
  10. a.停止Hook ()
  11. 运行 (“calc.exe”, 假, )
  12. a.开始Hook ()
  13.  
  14. 返回 (0)

api hook 模块我们在VIP群提供下载。

教程获取下载:


发布日期:

所属分类: 易语言 标签: