第八课 易语言调用C编写的Dll

C编写的Dll源码:

  1. /* Replace "dll.h" with the name of your header */
  2. #include "dll.h"
  3. #include <windows.h>
  4.  
  5. DLLIMPORT int _stdcall add(int a,int b)
  6. {
  7. 	return a+b;
  8. }
  9. DLLIMPORT int _stdcall sub(int a,int b)
  10. {
  11. 	return a-b;
  12. }
  13.  
  14. BOOL WINAPI DllMain(HINSTANCE hinstDLL,DWORD fdwReason,LPVOID lpvReserved)
  15. {
  16. 	switch(fdwReason)
  17. 	{
  18. 		case DLL_PROCESS_ATTACH:
  19. 		{
  20. 			break;
  21. 		}
  22. 		case DLL_PROCESS_DETACH:
  23. 		{
  24. 			break;
  25. 		}
  26. 		case DLL_THREAD_ATTACH:
  27. 		{
  28. 			break;
  29. 		}
  30. 		case DLL_THREAD_DETACH:
  31. 		{
  32. 			break;
  33. 		}
  34. 	}
  35.  
  36. 	/* Return TRUE on success, FALSE on failure */
  37. 	return TRUE;
  38. }

易语言调用C编写dll源码:

.版本 2
 
.DLL命令 add, 整数型, "test.dll", "add"
    .参数 a, 整数型
    .参数 b, 整数型
 
.DLL命令 sub, 整数型, "test.dll", "sub"
    .参数 a, 整数型
    .参数 b, 整数型
.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击
 
编辑框3.内容 = 到文本 (add (到整数 (编辑框1.内容), 到整数 (编辑框2.内容)))
 
.子程序 _按钮2_被单击
 
编辑框6.内容 = 到文本 (sub (到整数 (编辑框4.内容), 到整数 (编辑框5.内容)))


发布日期:

所属分类: 易语言 标签: