易语言PathIsRelativeA判断相对路径

是否相对路径PathIsRelativeA

  1. .版本 2
  2.  
  3. .DLL命令 是否相对路径_, 整数型, "shlwapi.dll", "PathIsRelativeA"
  4.     .参数 路径文本, 文本型, , pszPath

易语言调用

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

' PathIsRelativeA的作用是检查文件是否为相对路径。
' 返回1,相对路径。返回0,绝对路径。
标签_显示1.标题 = “somefile.txt”
标签_显示2.标题 = “c:\”
标签_显示3.标题 = “\\192.168.1.100\d$\javatools\”
标签_显示4.标题 = “http://www.microsoft.com/ms.htm”
标签_显示5.标题 = “www.microsoft.com”

.子程序 _按钮_是否相对路径_被单击

.判断开始 (是否相对路径_ (标签_显示1.标题) ≠ 0)
编辑框_效果1.内容 = “是”
.默认
编辑框_效果1.内容 = “否”
.判断结束
.判断开始 (是否相对路径_ (标签_显示2.标题) ≠ 0)
编辑框_效果2.内容 = “是”
.默认
编辑框_效果2.内容 = “否”
.判断结束
.判断开始 (是否相对路径_ (标签_显示3.标题) ≠ 0)
编辑框_效果3.内容 = “是”
.默认
编辑框_效果3.内容 = “否”
.判断结束
.判断开始 (是否相对路径_ (标签_显示4.标题) ≠ 0)
编辑框_效果4.内容 = “是”
.默认
编辑框_效果4.内容 = “否”
.判断结束
.判断开始 (是否相对路径_ (标签_显示5.标题) ≠ 0)
编辑框_效果5.内容 = “是”
.默认
编辑框_效果5.内容 = “否”
.判断结束


发布日期:

所属分类: 易语言 标签: