易语言控制程序暂停开始继续

一、使用变量控制程序的暂停和继续

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 是否暂停, 逻辑型

.子程序 _开始按钮_被单击
.局部变量 i, 整数型

开始按钮.禁止 = 真
处理事件 ()
.判断循环首 (i < 100000)
.如果真 (是否暂停 = 假)
i = i + 1
标签1.标题 = 到文本 (i)
.如果真结束
处理事件 ()

.判断循环尾 ()
开始按钮.禁止 = 假

.子程序 _暂停按钮_被单击

是否暂停 = 真

.子程序 _继续按钮_被单击

是否暂停 = 假

 

二、使用时钟控制程序的暂停开始和继续

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 累计变量, 整数型

.子程序 _开始按钮_被单击
.局部变量 i, 整数型

累计变量 = 0
时钟1.时钟周期 = 200

.子程序 _暂停按钮_被单击

时钟1.时钟周期 = 0

.子程序 _继续按钮_被单击

时钟1.时钟周期 = 200

.子程序 _时钟1_周期事件

累计变量 = 累计变量 + 1
标签1.标题 = 到文本 (累计变量)


发布日期:

所属分类: 易语言 标签: