易语言教程取数值注册项写删注册项

.版本 2
.支持库 spec
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击, , , 取文本注册项
.局部变量 a, 文本型
 
' 运行 (“regedit”, 假, )
a = 取文本注册项 (3, “AlbumArt\ThumbnailStorePath”, “取文本失败”)
调试输出 (a)
' C:\Program Files (x86)\The KMPlayer\AlbumArt\
编辑框1.内容 = a
 
.子程序 _按钮2_被单击, , , 取数值注册项
 
运行 (“regedit”,, )
调试输出 (取数值注册项 (#现行用户, “Software\Microsoft\Internet Explorer\Main\Do404Search”, ))

.子程序 _按钮3_被单击, , , 取字节集注册项
 
调试输出 (取字节集注册项 (#现行用户, “Software\Microsoft\Internet Explorer\Main\Do404Search”, ))

.子程序 _按钮4_被单击, , , 注册项是否存在
.局部变量 变量, 文本型
 
变量 = “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\511yj”
调试输出 (注册项是否存在 (4, 变量))
 
.子程序 _按钮5_被单击, , , 写注册项
.局部变量 变量, 文本型
 
运行 (“regedit”,, )
变量 = “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\511yj”
写注册项 (4, 变量, #引号 + “c:\1.exe” + #引号)

.子程序 _按钮6_被单击, , , 删除注册项
.局部变量 变量, 文本型
 
变量 = “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\511yj”
删除注册项 (4, 变量)


发布日期:

所属分类: 易语言 标签: