第六课易语言大漠剑侠情缘多线程木人巷点击寻路

>> 易语言大漠剑侠情缘输入坐标寻路

点击寻部分源码:

  1. .版本 2
  2.  
  3. .局部变量 str, 文本型
  4. .局部变量 a_str, 文本型, , "0"
  5. .局部变量 i, 整数型
  6.  
  7. 延时 ()
  8. i = 1
  9. .判断循环首 (i = 1)
  10.     str = FindStrFastE (612, 19, 801, 193, “寻”,002222-000000, 1, 数组序号)
  11.     a_str = 分割文本 (str,|, )
  12.     .如果 (到整数 (a_str [1]0))
  13.         延时 (300)
  14.         KeyPress (9, 数组序号)
  15.         延时 (300)
  16.         i = 1
  17.  
  18.     .否则
  19.         i = 0
  20.     .如果结束
  21.  
  22. .判断循环尾 ()
  23. MoveTo (a_str [2], a_str [3], 数组序号)
  24. 延时 (300)
  25. LeftClick (数组序号)
  26. 延时 (300)
  27. ' 移开鼠标
  28. MoveTo (a_str [2], a_str [3] + 23, 数组序号)
  29. 延时 (300)


发布日期:

所属分类: 易语言 标签: