511遇见易语言多线程大漠多线程-32大漠多线程模板-2日志

大漠多线程框架-2

1、OutputDebugStringA
可以使你的程序和调试器进行交谈。它要比创建日志文件容易,而且所有"真正的"调试器都能使用它。应用程序和调试器交谈的机制相当简单,
使我们认为这决不是一种低消耗的发送信息的方法,应用程序的运行速度会受到调试器的左右。
2、日志
初始化()
日志输出()
教程源码:
.版本 2
.支持库 EThread
.支持库 spec

.程序集 日志
.程序集变量 日志锁, 整数型, , , 许可证

.子程序 日志_初始化

日志锁 = 创建进入许可证 ()

.子程序 日志输出
.参数 info, 文本型

进入许可区 (日志锁)
调试输出 (info)
OutputDebugStringA (info)
退出许可区 (日志锁)


发布日期:

所属分类: 易语言 标签: