易语言API激活窗口源码

一、API

.版本 2

.DLL命令 寻找窗口, 整数型, "user32", "FindWindowA"
.参数 窗口句柄, 文本型
.参数 窗口名称, 文本型

.DLL命令 SetWindowPos, 整数型, "user32.dll", "SetWindowPos", , , Long,非零表示成功,零表示失败。会设置GetLastError
.参数 窗口句柄, 整数型, , Long,欲定位的窗口
.参数 定位类型, 整数型, , Long,窗口句柄。在窗口列表中,窗口hwnd会置于这个窗口句柄的后面。HWND_BOTTOM将窗口置于窗口列表底部HWND_TOP将窗口置于Z序列的顶部;Z序列代表在分级结构中,窗口针对一个给定级别的窗口显示的顺序HWND_TOPMOST将窗口置于列表顶部,并位于任何最顶部窗口的前面HWND_NOTOPMOST将窗口置于列表顶部,并位于任何最顶部窗口的后面
.参数 窗口新横坐标, 整数型, , Long,窗口新的x坐标。如hwnd是一个子窗口,则x用父窗口的客户区坐标表示
.参数 窗口新纵坐标, 整数型, , Long,窗口新的y坐标。如hwnd是一个子窗口,则y用父窗口的客户区坐标表示
.参数 窗口新宽度, 整数型, , Long,指定新的窗口宽度
.参数 窗口新高度, 整数型, , Long,指定新的窗口高度
.参数 显示方式, 整数型, , Long,包含了旗标的一个整数SWP_DRAWFRAME围绕窗口画一个框SWP_HIDEWINDOW隐藏窗口等等

二、主程序

.版本 2

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕
.局部变量 父窗口句柄, 整数型

父窗口句柄 = 寻找窗口 (取空白文本 (0), “MainContainer”)
编辑框1.内容 = 到文本 (父窗口句柄)
' 本源码来自易语言资源网(www.5A5X.com)

.子程序 _按钮1_被单击

SetWindowPos (到整数 (编辑框1.内容), 0, 0, 0, 0, 0, 3)
' 本源码来自易语言资源网(www.5A5X.com)

 


发布日期:

所属分类: 易语言 标签: