易语言组合框保存列表项目数据

教程截图

511遇见

易语言组合框保存列表项目数据源码:

.版本 2
.支持库 spec
.子程序 __启动窗口_创建完毕

置随机数种子 ()
.计次循环首 (10, )
组合框1.加入项目 (到文本 (取随机数 (111111111, 999999999)), )
.计次循环尾 ()

.子程序 _按钮1_被单击

组合框_保存列表项 (组合框1, 取运行目录 () + “\data.dat”)

.子程序 组合框_保存列表项
.参数 组合框, 组合框
.参数 参_保存文件, 文本型, 可空
.局部变量 局_字节集, 字节集
.局部变量 n, 整数型
.局部变量 项目文本, 文本型

局_字节集 = 到字节集 (到短整数 (组合框.取项目数 ()))
.计次循环首 (组合框.取项目数 (), n)
项目文本 = 组合框.取项目文本 (n - 1)
局_字节集 = 局_字节集 + 到字节集 (取文本长度 (项目文本)) + 到字节集 (项目文本)

.计次循环尾 ()

调试输出 (局_字节集)

写到文件 (参_保存文件, 局_字节集)

.子程序 组合框_读取列表项
.参数 组合框, 组合框
.参数 文件路径, 文本型

组合框.列表项目 = 读入文件 (文件路径)

.子程序 _按钮2_被单击

组合框_读取列表项 (组合框2, 取运行目录 () + “\data.dat”)

教程下载:


发布日期:

所属分类: 易语言 标签: