易语言大漠模块制作鼠标左键右键单击双击

模块命令源码

.版本 2

.子程序 LeftClick, 整数型, 公开, 按下鼠标左键(返回值:0失败,1成功)

返回 (obj.数值方法 (“LeftClick”, ))

.子程序 LeftDoubleClick, 整数型, 公开, 双击鼠标左键(返回值:0失败,1成功)

返回 (obj.数值方法 (“LeftDoubleClick”, ))

.子程序 LeftDown, 整数型, 公开, 按住鼠标左键(返回值:0失败,1成功)

返回 (obj.数值方法 (“LeftDown”, ))

.子程序 LeftUp, 整数型, 公开, 弹起鼠标左键(返回值:0失败,1成功)

返回 (obj.数值方法 (“LeftUp”, ))

.子程序 MiddleClick, 整数型, 公开, 按下鼠标中键(返回值:0失败,1成功)

返回 (obj.数值方法 (“MiddleClick”, ))

.子程序 MiddleDown, 整数型, 公开, 按住鼠标中键(返回值:0失败,1成功)

返回 (obj.数值方法 (“MiddleDown”, ))

.子程序 MiddleUp, 整数型, 公开, 弹起鼠标中键(返回值:0失败,1成功)

返回 (obj.数值方法 (“MiddleUp”, ))

.子程序 RightClick, 整数型, 公开, 按下鼠标右键(返回值:0失败,1成功)

返回 (obj.数值方法 (“RightClick”, ))

.子程序 RightDown, 整数型, 公开, 按住鼠标右键(返回值:0失败,1成功)

返回 (obj.数值方法 (“RightDown”, ))

.子程序 RightUp, 整数型, 公开, 弹起鼠标右键(返回值:0失败,1成功)

返回 (obj.数值方法 (“RightUp”, ))

.子程序 MoveR, 整数型, 公开, 鼠标相对于上次的位置移动rx,ry. 从6.1548版本开始,如果您使用了硬件模拟的前台鼠标,最好配合SetMouseSpeed和EnableMouseAccuracy函数来使用.(返回值:0失败,1成功)
.参数 rx, 整数型, , rx 整形数:相对于上次的X偏移
.参数 ry, 整数型, , ry 整形数:相对于上次的Y偏移

返回 (obj.数值方法 (“MoveR”, rx, ry))

.子程序 MoveTo, 整数型, 公开, 把鼠标移动到目的点(x,y)(返回值:0失败,1成功)
.参数 x, 整数型, , x 整形数:X坐标
.参数 y, 整数型, , y 整形数:Y坐标

返回 (obj.数值方法 (“MoveTo”, x, y))

.子程序 MoveToEx, 文本型, 公开, 把鼠标移动到目的范围内的任意一点,返回值(返回要移动到的目标点. 格式为x,y. 比如MoveToEx 100,100,10,10,返回值可能是101,102)
.参数 x, 整数型, , x 整形数:X坐标
.参数 y, 整数型, , y 整形数:Y坐标
.参数 w, 整数型, , w 整形数:宽度(从x计算起)
.参数 h, 整数型, , h 整形数:高度(从y计算起)

返回 (obj.数值方法 (“MoveToEx”, x, y, w, h))

例程源码

.版本 2
 
.子程序 _按钮3_被单击, , , LeftClick
 
插件初始化 ()
SetPath (取运行目录 ())
绑定 ()
MoveTo (761, 358)
延时 (100)
LeftClick ()
UnBindWindow ()

视频链接


发布日期:

所属分类: 易语言 标签: