29软件安完整性Sha1自校验

Sha1生成源码:

  1. .版本 2
  2.  
  3. .子程序 _按钮1_被单击
  4. .局部变量 局_文件号, 整数型
  5. .局部变量 局_字节集, 字节集
  6. .局部变量 局_Sha1, 文本型
  7.  
  8. .判断开始 (文件是否存在 (编辑框1.内容))
  9.     局_文件号 = 打开文件 (编辑框1.内容, , )
  10.     局_字节集 = 读入字节集 (局_文件号, 取文件长度 (局_文件号))
  11.     局_Sha1 = 校验_取sha1 (局_字节集)
  12.     编辑框2.内容 = 局_Sha1
  13.     移到文件尾 (局_文件号)
  14.     写出字节集 (局_文件号, 到字节集 (局_Sha1))
  15.     关闭文件 (局_文件号)
  16.     信息框 (“Sha1写出成功!”, 0, , )
  17.  
  18. .默认

Sha1验证源码

.版本 2

.子程序 自校验_Sha1, 逻辑型, 公开, 返回真校验成功,假说明文件被修改
.局部变量 局_运行目录, 文本型
.局部变量 局_执行文件名称, 文本型
.局部变量 局_字节集, 字节集
.局部变量 局_原Sha1, 文本型
.局部变量 局_Sha1, 文本型

局_运行目录 = 取运行目录 ()
局_执行文件名称 = 取执行文件名 ()
局_字节集 = 读入文件 (局_运行目录 + “\” + 局_执行文件名称)
局_原Sha1 = 到文本 (取字节集右边 (局_字节集, 40))
_启动窗口.编辑框1.内容 = 局_原Sha1
局_字节集 = 取字节集左边 (局_字节集, 取字节集长度 (局_字节集) - 40)
局_Sha1 = 校验_取sha1 (局_字节集)
_启动窗口.编辑框2.内容 = 局_Sha1
.判断开始 (局_Sha1 = 局_原Sha1)
返回 (真)
.默认

.判断结束
返回 (假)


发布日期:

所属分类: 易语言 标签: