511遇见易语言软件本地注册验证14-注册成码两种算法同一种结果

序列号算法F1源码:

.版本 2
.支持库 dp1
 
.子程序 F1, 文本型, , 验证码序列号的生成
.参数 硬盘特征字, 长整数型
.局部变量 T, 文本型
.局部变量 i, 整数型
.局部变量 text, 文本型, , "8"
.局部变量 b, 文本型
.局部变量 a, 文本型
 
T = 到大写 (取数据摘要 (到字节集 (硬盘特征字)))
.计次循环首 (8, i)
    text [i] = 取文本左边 (T, 4)
    T = 取文本右边 (T, 取文本长度 (T)4)
    b = text [i]
    .如果 (i = 1)
        a = a + “” + b
    .否则
        a = a + “-” + b
    .如果结束
 
.计次循环尾 ()
' 40BF-0E9B-B1DF-5BBE-4662-F2E9-639E-E24E
返回 (a)

序列号算法F2源码:

.版本 2
.支持库 dp1
 
.子程序 F2, 文本型, 公开, 在客户端的话
.局部变量 T, 文本型
.局部变量 i, 整数型
.局部变量 text, 文本型, , "8"
.局部变量 b, 文本型
.局部变量 a, 文本型
.局部变量 硬盘特征字, 长整数型
 
硬盘特征字 = 系统_取特征码综合 ()
T = 到大写 (取数据摘要 (到字节集 (硬盘特征字)))
.计次循环首 (取文本长度 (T) ÷ 4, i)
    text [i] = 取文本右边 (T, 4)
    T = 取文本左边 (T, 取文本长度 (T)4)
    b = text [i]
    .如果 (i = 1)
        a = b + “” + a
    .否则
        a = b + “-” + a
    .如果结束
 
.计次循环尾 ()
返回 (a)

验证F1和F2源码:

.版本 2
 
.子程序 F1和F2, 逻辑型, 公开, 返回真验证成功
.参数 f1, 文本型
.参数 f2, 文本型
 
.判断开始 (f1 = f2)
    返回 ()
.默认
    返回 ()


发布日期:

所属分类: 易语言 标签: