28软件安完整性CRC32自校验验证测试端

自校验验证测试端源码:

  1. .版本 2
  2.  
  3. .子程序 自效验_CRC32, 逻辑型, 公开
  4. .局部变量 文件名, 文本型
  5. .局部变量 原exe字节集, 字节集
  6. .局部变量 原exe长度, 整数型
  7. .局部变量 PE文件头位置, 整数型
  8. .局部变量 文件原始的CRC32, 字节集
  9. .局部变量 当前文件的CRC32, 字节集
  10.  
  11. ' 取执行文件名 ()
  12. 文件名 = 取空白文本 (256)
  13. GetModuleFileName (0, 文件名, 256)
  14. 原exe字节集 = 读入文件 (文件名)
  15. 原exe长度 = 取字节集长度 (原exe字节集)
  16. ' 查找PE
  17. PE文件头位置 = 寻找字节集 (原exe字节集, { 80.69 }, )
  18. ' 定位到PE文件头前4个字节处,并读出储存在这里的CRC32值
  19. 文件原始的CRC32 = 取字节集中间 (原exe字节集, PE文件头位置 - 4, 4)
  20. 当前文件的CRC32 = 到字节集 (校验_取crc32整数 (取字节集中间 (原exe字节集, PE文件头位置, 原exe长度)))
  21. .判断开始 (文件原始的CRC32 ≠ { 0, 0, 0, 0 })
  22.     .判断开始 (文件原始的CRC32 = 当前文件的CRC32)
  23.         返回 (真)
  24.     .默认
  25.         返回 (假)
  26.     .判断结束
  27.  
  28. .默认
  29.     返回 (假)
  30. .判断结束

CRC32自校验生成端示意图:

511遇见


发布日期:

所属分类: 后端 标签: