511遇见易语言多线程大漠多线程-18多线程启动方式许可证互斥

多线程-许可证启动方式

启动多线程=========创建多个许可证========== 一个子程序

启动多线程=========创建一个许可证========== 多个子程序

课程源码:

.版本 2
.支持库 EThread
.支持库 spec
 
.程序集 窗口程序集_启动窗口
.程序集变量 thwnd1
.程序集变量 thwnd2
.程序集变量 许可证, , , , 互斥
.程序集变量 许可证2
 
.子程序 __启动窗口_创建完毕
 
 
 
.子程序 _按钮1_被单击
 
启动线程 (&线程1, , thwnd1)
 
 
.子程序 线程1
.局部变量 i, 整数型
 
进入许可区 (许可证)
.计次循环首 (99, i)
    编辑框1.加入文本 (“线程-1-正在执行” + 到文本 (i) + #换行符)
    延迟 (1000)
.计次循环尾 ()
 
退出许可区 (许可证)
 
.子程序 _按钮3_被单击
 
许可证 = 创建进入许可证 ()
' ’许可证2 = 创建进入许可证 ()
 
.子程序 _按钮5_被单击
 
强制结束线程 (thwnd1)
 
 
.子程序 _按钮2_被单击
 
启动线程 (&线程1, , thwnd2)
 
 
.子程序 线程2
.局部变量 i, 整数型
 
 
.计次循环首 (99, i)
    进入许可区 (许可证2)
    编辑框2.加入文本 (“线程-2-正在执行” + 到文本 (i) + #换行符)
    延迟 (1000)
    退出许可区 (许可证2)
 
.计次循环尾 ()
 
.子程序 _按钮4_被单击
 
强制结束线程 (thwnd2)


发布日期:

所属分类: 后端, 易语言 标签: