易语言大漠单线程模块制作解除绑定等命令

视频教程源码:

.版本 2

.子程序 UnBindWindow, 整数型, 公开, 解除绑定窗口,并释放系统资源 UnBindWindow(返回值:0失败,1成功)

返回 (obj.数值方法 (“UnBindWindow”, ))

.子程序 DownCpu, 整数型, 公开, 降低目标窗口所在进程的CPU占用DownCpu(返回值:0失败,1成功)
.参数 rate, 整数型, , rate 整形数: 取值范围大于0 取值为0 表示关闭CPU优化. 这个值越大表示降低CPU效果越好.

返回 (obj.数值方法 (“DownCpu”, rate))

.子程序 EnableBind, 整数型, 公开, 设置是否暂时关闭或者开启后台功能. 默认是开启. EnableBind(返回值:0失败,1成功)
.参数 enable, 整数型, , 0 全部关闭(图色键鼠都关闭,也就是说图色,键鼠都是前台,-1 只关闭图色.(也就是说图色是normal前台. 键鼠不变),1 开启(恢复原始状态),5 同0,也是全部关闭,但是这个模式下,就算窗口在前后台切换时,属性dx.public.active.message的效果也一样不会失效.

返回 (obj.数值方法 (“EnableBind”, enable))

.子程序 EnableFakeActive, 整数型, 公开, 设置是否开启后台假激活功能. 默认是关闭.EnableFakeActive(返回值:0失败,1成功)
.参数 enable, 整数型, , 0关闭,1开启

返回 (obj.数值方法 (“EnableFakeActive”, enable))

.子程序 EnableIme, 整数型, 公开, 设置是否关闭绑定窗口所在进程的输入法.EnableIme(返回值:0失败,1成功)
.参数 enable, 整数型, , 0关闭,1开启

返回 (obj.数值方法 (“EnableIme”, enable))

.子程序 EnableKeypadMsg, 整数型, 公开, 是否在使用dx键盘时开启windows消息.默认开启.EnableKeypadMsg(返回值:0失败,1成功)
.参数 enable, 整数型, , 0关闭,1开启

返回 (obj.数值方法 (“EnableKeypadMsg”, enable))

.子程序 EnableKeypadPatch, 整数型, 公开, 键盘消息发送补丁. 默认是关闭.EnableKeypadPatch(返回值:0失败,1成功)
.参数 enable, 整数型, , 0关闭,1开启

返回 (obj.数值方法 (“EnableKeypadPatch”, enable))

.子程序 EnableKeypadSync, 整数型, 公开, 键盘消息采用同步发送模式.默认异步.EnableKeypadSync(返回值:0失败,1成功)
.参数 enable, 整数型, , 0 禁止同步,1开启同步
.参数 time_out, 整数型, , 单位是毫秒,表示同步等待的最大时间.

返回 (obj.数值方法 (“EnableKeypadSync”, enable, time_out))

.子程序 EnableMouseMsg, 整数型, 公开, 是否在使用dx鼠标时开启windows消息.默认开启.EnableMouseMsg(返回值:0失败,1成功)
.参数 enable, 整数型, , 0禁止,1开启

返回 (obj.数值方法 (“EnableMouseMsg”, enable))

.子程序 EnableMouseSync, 整数型, 公开, 鼠标消息采用同步发送模式.默认异步.EnableMouseSync(返回值:0失败,1成功)
.参数 enable, 整数型, , 0 禁止同步,1开启同步
.参数 time_out, 整数型, , 单位是毫秒,表示同步等待的最大时间.

返回 (obj.数值方法 (“EnableMouseSync”, enable, time_out))

.子程序 EnableRealKeypad, 整数型, 公开, 键盘动作模拟真实操作,点击延时随机.EnableRealKeypad(返回值:0失败,1成功)
.参数 enable, 整数型, , 0关闭模拟,1开启模拟

返回 (obj.数值方法 (“EnableRealKeypad”, enable))

.子程序 EnableRealMouse, 整数型, 公开, 鼠标动作模拟真实操作,带移动轨迹,以及点击延时随机.EnableRealMouse(返回值:0失败,1成功)
.参数 enable, 整数型, , 0 关闭模拟,1 开启模拟(直线模拟),2 开启模式(随机曲线,更接近真实)
.参数 mousedelay, 整数型, , 单位是毫秒. 表示在模拟鼠标移动轨迹时,每移动一次的时间间隔.这个值越大,鼠标移动越慢.
.参数 mousestep, 整数型, , 表示在模拟鼠标移动轨迹时,每移动一次的距离. 这个值越大,鼠标移动越快速.

返回 (obj.数值方法 (“EnableRealMouse”, enable, mousedelay, mousestep))

.子程序 EnableSpeedDx, 整数型, 公开, 设置是否开启高速dx键鼠模式。 默认是关闭.EnableSpeedDx(返回值:0失败,1成功)
.参数 enable, 字节型, , 0关闭,1开启

返回 (obj.数值方法 (“EnableSpeedDx”, enable))

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: