易语言教程重定义数组和复制数组

一、官方源码

重定义数组
调用格式: 〈无返回值〉 重定义数组 (通用型变量数组 欲重定义的数组变量,逻辑型 是否保留以前的内容,整数型 数组对应维的上限值,... ) - 系统核心支持库->数组操作
英文名称:ReDim
本命令可以重新定义指定数组的维数及各维的上限值。本命令为初级命令。命令参数表中最后一个参数可以被重复添加。
参数<1>的名称为“欲重定义的数组变量”,类型为“通用型(all)”,提供参数数据时只能提供变量数组。
参数<2>的名称为“是否保留以前的内容”,类型为“逻辑型(bool)”,初始值为“假”。
参数<3>的名称为“数组对应维的上限值”,类型为“整数型(int)”。

操作系统需求: Windows、Linux、Unix
复制数组
调用格式: 〈无返回值〉 复制数组 (通用型变量数组 复制到的数组变量,通用型数组 待复制的数组数据) - 系统核心支持库->数组操作
英文名称:CopyAry
将数组数据复制到指定的数组变量,该数组变量内的所有数据和数组维定义信息将被全部覆盖。本命令为初级命令。
参数<1>的名称为“复制到的数组变量”,类型为“通用型(all)”,提供参数数据时只能提供变量数组。
参数<2>的名称为“待复制的数组数据”,类型为“通用型(all)”,提供参数数据时只能提供数组数据。

操作系统需求: Windows、Linux、Unix

二、教程源码

.版本 2
.支持库 spec

.子程序 _按钮4_被单击, , , 重定义数组-a
.局部变量 上限维值, 整数型

上限维值 = 到整数 (编辑框1.内容)
重定义数组 (数组a, 假, 上限维值)

.子程序 _按钮5_被单击, , , 重定义数组-b

重定义数组 (数组b, 假, 7, 10, 3)

.子程序 _按钮6_被单击, , , 重定义数组-真假
.局部变量 arr_n, 整数型, , "0"

arr_n = { 1, 2, 3 }
' 重定义数组 (arr_n, 假, 6)
重定义数组 (arr_n, 真, 5)
调试输出 (arr_n)

.子程序 _按钮7_被单击, , , 复制数组
.局部变量 数组1, 文本型, , "0"
.局部变量 数组2, 文本型, , "0"

数组1 = { “我”, “爱”, “易”, “语”, “言” }
' 复制数组 (数组2, 数组1)
数组2 = 数组1
调试输出 (数组2)


发布日期:

所属分类: 易语言 标签: