511遇见易语言软件本地注册验证-16-软件序列号(特征字+QQ+限制时间)

软件序列号(特征字+QQ+限制时间)源码:

.版本 2
.支持库 spec
 
.子程序 注册码_机器特征字_QQ_限制时间_生成, 文本型, 公开, 注册机
.参数 客户机器特征字, 长整数型
.参数 QQ, 文本型
.参数 时间, 日期时间型
.参数 是否永久, 逻辑型, 可空, 默认为空为真永久使用,软件限制时间
.局部变量 临时时间, 日期时间型
.局部变量 到期时间, 文本型
.局部变量 特征字, 文本型
.局部变量 用户名, 文本型
.局部变量 代码数组, 整数型, , "0"
.局部变量 代码, 文本型
.局部变量 T, 文本型
.局部变量 Y, 文本型, , ,.局部变量 M, 文本型, , ,.局部变量 D, 文本型, , ,.局部变量 i, 整数型
 
.如果 (是否为空 (是否永久))
    临时时间 = [9999121]
.否则
    临时时间 = 时间
.如果结束
Y = 到文本 (取年份 (临时时间))
M = 到文本 (取月份 (临时时间))
M = 选择 (取文本长度 (M)1,0” + M, M)
D = 到文本 (取日 (临时时间))
D = 选择 (取文本长度 (D)1,0” + D, D)
到期时间 = 到文本 (左移 (到数值 (Y + M + D), 4))
' 处理参数
到期时间 = 进制转换 (到期时间, 10, 16)
特征字 = 进制转换 (到文本 (客户机器特征字), 10, 16)
用户名 = 进制转换 (QQ, 10, 16)
T = 到期时间 + “y” + 特征字 + “j” + 用户名
重定义数组 (代码数组, 假, 取文本长度 (T))
.计次循环首 (取文本长度 (T), i)
    代码数组 [i] = 取代码 (到大写 (T), i)
    代码 = 到文本 (代码数组 [i]) + 代码
.计次循环尾 ()
调试输出 (T)
调试输出 (代码)
返回 (代码)


发布日期:

所属分类: 易语言 标签: