易语言大漠多线程模板-9多线程全部暂停恢复

多线程全部暂停恢复

.版本 2
 
.子程序 多线程_暂停, , , 设置暂停标识
.参数 主序号, 整数型
 
' 判断主序号
.如果真 (主序号 ≤ 0 或 主序号 ≥ MaxHwnd)
    返回 ()
 
.如果真结束
' 判断句柄
.如果真 (线程信息 [主序号].线程句柄 = 0)
    返回 ()
.如果真结束
 
' 主线程标识
.如果真 (线程信息 [主序号].线程状态 = #线程状态_正在运行 或 线程信息 [主序号].线程状态 = #线程状态_正在恢复)
    线程信息 [主序号].是否暂停 = 真
    线程信息 [主序号].线程状态 = #线程状态_正在暂停
 
.如果真结束
 
' 副线程的标识
.如果真 (线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在运行 或 线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在恢复)
    线程信息 [主序号 + MaxHwnd].是否暂停 = 真
    线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在暂停
 
 
.如果真结束
 
日志输出 (“暂停 主序号” + 到文本 (主序号))
 
UI_更新 (主序号, #UI_更新)
 
 
.子程序 多线程_恢复, , , 设置恢复标识
.参数 主序号
 
' 判断主序号
.如果真 (主序号 ≤ 0 或 主序号 ≥ MaxHwnd)
    返回 ()
 
.如果真结束
' 判断句柄
.如果真 (线程信息 [主序号].线程句柄 = 0)
    返回 ()
.如果真结束
' 主线程标识
.如果真 (线程信息 [主序号].线程状态 = #线程状态_暂停 或 线程信息 [主序号].线程状态 = #线程状态_正在运行)
    线程信息 [主序号].是否暂停 = 假
    线程信息 [主序号].线程状态 = #线程状态_正在恢复
 
.如果真结束
 
' 副线程的标识
.如果真 (线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_暂停 或 线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在暂停)
    线程信息 [主序号 + MaxHwnd].是否暂停 = 假
    线程信息 [主序号 + MaxHwnd].线程状态 = #线程状态_正在恢复
 
 
.如果真结束
 
日志输出 (“恢复 主序号” + 到文本 (主序号))
 
UI_更新 (主序号, #UI_更新)

优酷视频链接


发布日期:

所属分类: 易语言 标签: