511遇见易语言软件本地注册验证-17-机器特征字_QQ_限制时间_反算

机器特征字_QQ_限制时间_反算yuanm

.版本 2
 
.子程序 注册码_机器特征字_QQ_限制时间_反算, 文本型
.参数 参_注册码, 文本型
.局部变量 代码, 文本型
.局部变量 text, 文本型, , "0"
.局部变量 b, 文本型, , , 就是生成的注册码
.局部变量 n, 整数型
.局部变量 还原文本, 文本型, , , 就是生成中的T
 
代码 = 参_注册码
重定义数组 (text,, 取文本长度 (代码) ÷ 2)
 
.计次循环首 (取文本长度 (代码) ÷ 2, n)
    text [n] = 取文本左边 (代码, 2)
    代码 = 取文本右边 (代码, 取文本长度 (代码)2)
    b = b + text [n]
    ' 调试输出 (b)
    ' 还原文本 = 字符 (到数值 (text [n])) + 还原文本
 
.计次循环尾 ()
返回 (b)


发布日期:

所属分类: 易语言 标签: