易语言获取日期时间星期格式化时间

程序集变量

.版本 2
 
.程序集 程序集1
.程序集变量 时间, 日期时间型

礼拜几转换

.版本 2
 
.子程序 转换, 文本型
.参数 日期, 日期时间型
 
返回 (多项选择 (取星期几 (日期), “星期日”, “星期一”, “星期二”, “星期三”, “星期四”, “星期五”, “星期六”))

格式化时间

.版本 2
 
.子程序 格式化时间
.局部变量 结果, 文本型
 
时间 = 取现行时间 ()
结果 = 到文本 (取年份 (时间)) + “-” + 到文本 (取月份 (时间)) + “-” + 到文本 (取日 (时间)) + “ ” + 到文本 (取小时 (时间)) + “:” + 到文本 (取分钟 (时间)) + “:” + 到文本 (取秒 (时间)) + “ ” + 转换 (时间)
输出调试文本 (结果)

发布日期:

所属分类: 易语言 标签: