易语言乐玩插件右键鼠标字符输入按键

乐玩模块源码:

.版本 2

.子程序 KeyPress, 整数型, 公开, 0:失败,1:成功
.参数 vk_code
.参数 num

返回 (obj.数值方法 (“KeyPress”, vk_code, num))

.子程序 KeyPressStr, 整数型, 公开, 0:失败,1:成功
.参数 key_str, 文本型
.参数 delay

返回 (obj.数值方法 (“KeyPressStr”, key_str, delay))

.子程序 RightClick, 整数型, 公开, 0:失败,1:成功

返回 (obj.数值方法 (“RightClick”, ))

.子程序 SendString, 整数型, 公开, 0:失败,1:成功
.参数 str, 文本型
.参数 mod
.参数 hwnd

返回 (obj.数值方法 (“SendString”, str, mod, hwnd))

.子程序 RightDown, 整数型, 公开, 0:失败,1:成功

返回 (obj.数值方法 (“RightDown”, ))

.子程序 RightUp, 整数型, 公开, 0:失败,1:成功

返回 (obj.数值方法 (“RightUp”, ))

乐玩模块调用测试

.版本 2
 
.子程序 _按钮16_被单击
 
' 按键F4打开物品栏
l.KeyPress (115, 1)
延时 (1000)
' 找药品图
l.FindPic (601, 58, 780, 345,3.bmp, “000000”, 0.95, 2, 0, 0, 0, 0, 0)
延时 (1000)
l.MoveTo (l.GetX (), l.GetY ())
延时 (3000)
' l.RightClick ()
' 右键按下,然后右键UP弹起,假如右键单击失效,可以采用这样的替换方案
l.RightDown ()
延时 (1000)
l.RightUp ()
' 输入要取的药品的数量
延时 (3000)
' l.SendString (2, 0, hwnd)
l.KeyPressStr (2, 50)
' 输入要取的药品后,按下回车键
延时 (3000)
l.KeyPress (13, 1)
延时 (5000)
' 关闭药品栏窗口
l.KeyPress (115, 1)

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: