易语言PathRenameExtension修改文件扩展名

易语言API

PathRenameExtensionA的作用是更改文件名的扩展名。
参数说明:
第一个参数,提供全路径文件名变量。
第二个参数,提供更改后的扩展名。

.版本 2
.DLL命令 改文件扩展名_, 整数型, "shlwapi.dll", "PathRenameExtensionA"
    .参数 文件名, 文本型, , pszPath
    .参数 扩展名, 文本型, , pszExt

调用

需要两个文本框,一个是原来文件的全路径,一个是修改后的扩展名称。

.版本 2

.子程序 _按钮_改文件扩展名_被单击
.局部变量 局部_文件名, 文本型
.局部变量 局部_扩展名, 文本型

局部_文件名 = “c:\windows\system32\user32.txt”
局部_扩展名 = 编辑框_扩展名.内容
.如果真 (局部_扩展名 = “”)
局部_扩展名 = “.dll”
.如果真结束
.如果真 (取文本左边 (局部_扩展名, 1) ≠ “.”)
局部_扩展名 = “.” + 局部_扩展名
.如果真结束
.如果真 (改文件扩展名_ (局部_文件名, 局部_扩展名) ≠ 0)
编辑框_文件名.内容 = 局部_文件名
编辑框_文件名.起始选择位置 = 取文本长度 (局部_文件名) - 取文本长度 (编辑框_扩展名.内容)
编辑框_文件名.被选择字符数 = 取文本长度 (编辑框_扩展名.内容)
编辑框_文件名.获取焦点 ()


发布日期:

所属分类: 易语言 标签: